首页 > 编程学习记录 > 易语言传送支持库:提示“无法获得文件大小”

201612月20

易语言传送支持库:提示“无法获得文件大小”

作者:admin 0 Comments 发表评论

山东时时彩十一选五 www.zqojk.com.cn 明明是按照教程来写的代码,但是提示“无法获得文件大小”,然后就没有然后了,直接停止了下载。测试发现如果是下载MP3、exe等的链接没有问题,但是下载HTML文件时有问题,下面是截图和代码:

提示:无法获取文件大小

//pan.baidu.com/s/1bpgOQQV

如果不愿意下载,可以直接复制下面的:

.版本 2
.支持库 downlib
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 下载对象, 下载对象
.程序集变量 配置信息, 任务参数

.子程序 _按钮1_被单击

配置信息.类型 = #传送常量.下载

配置信息.文件地址 = “//im.qq.com/”
配置信息.本地文件路径 = “F:\99.html”
配置信息.默认线程数 = 1
配置信息.连接超时 = 20000
配置信息.发送超时 = 20000
配置信息.接收超时 = 20000
配置信息.下载速度 = 0

配置信息.日志回调函数 = &日志回调函数子程序 ‘ 测试可以不用
配置信息.交互回调函数 = &交互回调函数子程序 ‘ 必须要有
下载对象.增加新任务 (配置信息)
.子程序 日志回调函数子程序
.参数 线程信息, 整数型
.参数 消息产生的时间, 文本型
.参数 消息的正文, 文本型
.参数 消息类型, 整数型
.参数 对象信息, 整数型

调试输出 (消息的正文)
.子程序 交互回调函数子程序
.参数 消息类型, 整数型
.参数 线程信息, 整数型
.参数 第三个参数, 整数型
.参数 第四个参数, 整数型
.参数 对象信息, 整数型
调试输出 (消息类型)

补充:通过经过进一步测试,如果下载的网页是纯静态页面,就可以正常下载,如果是伪静态或者动态页面,就不能正常下载,都是提示无法获取文件大小,然后就停止了下载。用“HTTP读文件”倒是可以下载正常,但是这样就没法获取到下载进度等信息。

用HTTP下载的方式写的多线程的源码:

//pan.baidu.com/s/1miBEHXe

推荐阅读相关文章:编程学习记录

本文地址://www.zqojk.com.cn/chuansongzhichiku.html
版权所有 © 转载时必须以链接形式注明作者和原始出处!

本文目前尚无任何评论.

发表评论

  • 梨子的滋味说不清楚就要亲口偿偿,什么不提倡在一些省搞社会主义,在一些省搞自由市场经济呢,却把这一理念转移方向呢? 2019-04-21
  • 江苏要求在中小学普及编程教育 为人工智能发展培养人才 2019-04-21
  • 马克思主义,不会改变人类历史发展的进程和规律,它只是揭示了这个不可更改的客观规律。人类社会发展的进程,只决定于工人阶级的觉悟。现在是工人阶级丧失了革命觉悟的时期 2019-04-21
  • 莆田市:构建1536多元化解体系 实现线上线下全域覆盖 2019-04-21
  • 80亩山林被“剃光头” 森林公安半年未结案 2019-04-20
  • 夏季肠道容易“中风” 2019-04-20
  • 火爆!可兰白克两引冲突掀翻对手 杜锋直接换他下场 2019-04-20
  • 习近平日内瓦演讲一周年世界为何青睐"人类命运共同体" 2019-04-20
  • 承载历史使命的 “乡村振兴”,城乡共同参与 2019-04-19
  • 嘱望上合 青岛之约 2019-04-19
  • [微笑]那就是管理问题了,跟免不免费本身不相干! 2019-04-19
  • 六一记忆:不同的年代 同样的快乐 2019-04-18
  • 中青报:“三天朋友圈可见”的背后 2019-04-18
  • 你反来复去说1+1=2,真痴呆了?你应该讲点其他的吧,譬如,1+1=2,是客观事实还是规律,是真理还是谬误。 2019-04-18
  • 新时代 新气象 新作为 学习宣传贯彻党的十九大精神 2019-04-17
  • 486| 374| 742| 570| 287| 413| 361| 693| 329| 425|